The Unofficial Poster Child for Notes and Domino (or whatever IBM calls it)

 
alt

Robert Baehr

 

    Domino 9.0.1 Post Upgrade Issue

    Robert Baehr  February 7 2014 01:34:45 PM
    Greetings:

    Back in December, after application functional testing passed with high marks under 9.0.1, we took the deep dive into Domino 9.0.1, Notes 9.0.1 and the latest Traveler for that platform.    And everything went almost perfect!  Please note that we never had an issue with 8.5.3 UP1 + FPs, even though the application in question is 22GB and contains 1.8 million documents.

    Production Environment:
    - Windows Server 2008 R2 (Hyper-V), the VM is located on a fast SAN.
    - Domino 9.0.1

    Test Environment (to help solve this problem):
    - Windows 7
    - Domino 9.0.1
    - Read below before coming to conclusions about Windows 7


    Overview:
    The problem we are having is that one of the main views (450K documents, at most 5 levels of responses per document) does not "refresh" completely.   The "twisties" are missing, and category expansion is impossible.    F9 does nothing, but a Shift_F9 works every time (but.. takes time).  This was true of both Production and Test environments.

    A little in-depth architectural stuff:

    Each evening, an agent runs that updates certain view selection formulas (and this view is not one of them).   Then, another server-agent uses view.refresh to update the view based on the new selection formula.   For convenience, the agent processes all views in the application, regardless of their view selection formula update status.  Note:  The agent that updated the view selection formulas runs on Production, and the changes replicate in to the Test environment before any further agent activity.

    What I have tried so far on the Test Environment:
    - Tore LOG.NSF apart - I cannot find anything out of the norm
    - The agents DO complete, as always.
    - Split the view up into to smaller views (failed)
    - FIXUP , COMPACT -i, and UPDALL -R (failed)
    - Made a new replica of the application (failed)
    - Wrote an agent to perform an UPDALL -R nightly, but it takes too long based on other agents that need to process first.
    - SET CONFIG DEBUG=1 and SET CONFIG DEBUG_NIF=1, parsed a 3GB+ text file with a freeware tet editor, and found the "update took longer than 30 minutes to complete" message on the problem view.

    Interestingly, I decided to downgrade the Test Environment from 9.0.1 back to 8.5.3.   By surprise, that seems to have fixed the problem, for every early morning check of both systems show that the 8.5.3 environment is pristine, whereas the 9.0.1 environment still has the incomplete view refresh.  In short, it works like a gem on 8.5.3, but not on 9.0.1.

    I have a PMR open to IBM on this, and will advise of the outcome.  If anyone else has experienced this, and, can offer a solution that solves this problem (not a hack - a real solution), I thank you in advance, and, will buy you a beer @ Connect-O-Sphere-exa 2015*, assuming I get to go, and you get to go!

    More to come - stay tuned!
    Robert Baehr
    The Unofficial Poster Child for Notes and Domino (or whatever IBM calls it)


    *Free beer offer limited to one free beer to the first person who offers a real solution that is not working for IBM Support.   Oh, what the hell - I'll even include the IBM Support engineer if he/she solves this one quickly!

    -